Jump to content

Custom Search






REGISTER YOUR BOSS 302 @ the Ford Authorized Boss 302 Registry Here!


Welcome to the Boss 302 Forum Club


Sign In  Log in with Facebook

Create Account
Welcome to the Boss 302 Forum Club. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Member benefits:
  • Join your Boss 302 region
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos and more. . .
Click here to register now
 
 
Guest Message by DevFuse

Photo
- - - - -

Oil Pressure Sensor


  • Please log in to reply
14 replies to this topic

#1 eljefe

eljefe

    New Boss 302 Member

  • Northeast Region
  • 5 posts
  • Region:U.S., Northeast
  • Current Vehicle:BOSS 302 Laguna Seca
  • Boss 302's Year:2012

Posted 05 August 2017 - 07:52 PM

Hello! First post here. I need your help.
 
I recently purchase a 2012 LS (#495) with 3500 miles. I was out today and the oil warning light came on plus the oil pressure gauge in the center pod stopped working.
 
I pulled over and checked under the car for any sign of oil leaking then checked the oil level. No signs of oil leaking under the car and the oil level was a little bit below the top hole on the dip stick. I got back in the car, started it and moved it forward a bit to check the ground for any sign of oil, nothing.
 
Started it again and drove it home. Thankfully I wasn't far from home when this happened. The car ran fine, no sign of anything unusual except the warning light and oil pressure gauge not working.
 
My questions is, did my oil pressure sensor go belly up?
 
After I got home I put the car on ramps and checked things out a little further:
1) No sign of oil leaking anywhere around the pan, pan plug, filter, pan level sensor or pressure sensor/sender on the block.
2) I unplugged and plugged back in the oil level sensor on the side of the oil pan.
3) Tried the track key and even disconnected the battery hoping to reset things in case there was some computer gremlin at work.
4) Scanned for fault codes using ODB2 scanner app, nothing.
5) Used a circuit tester on the wires coming out of the pressure sensor and it lit up fine. (Now that I think about it, I didn't do this on the oil level sensor, will try that too)
 
Thank you!







Lose this advertisement by becoming a member of the Boss 302 Club.

It's totally free, has great benefits and unlocks features on this site. Click here to learn more.




#2 Rich B.

Rich B.

    Rich B.

  • Northeast Region
  • 3,449 posts
  • Region:U.S., Northeast
  • Current Vehicle:Boss 302 and '16 Buick LaCrosse
  • Boss 302's Year:2013

Posted 06 August 2017 - 05:19 AM

Tough question. Unless sender is common to both dash lamp and pod gauge seems unlikely both would go on the blink at the same time? Perhaps oil isn't the correct 5-50 wt. and loosing viscosity? Know many change oil using different brands of oil and/or the same as used for a GT. Can't say if this would create a problem or not.

#3 Ginger

Ginger

    New Boss 302 Member

  • Member
  • Pip
  • 157 posts
  • Region:Other
  • Current Vehicle:2012 Boss 302
  • Boss 302's Year:2012

Posted 06 August 2017 - 06:07 AM

Is car NA or boosted?

I read that boosted cars need to up grade there oil pump gears.

maybe you can install a test oil gauge just to see and be able to check to see if your factory gauge is working.

 

If you did loose all oil pressure, is there any safety built into the computer to shut down the engine.

 

Please keep us posted on what you find and do. This is how we all learn. BOSS school...ROOM 302  :noobie: 


  • LSECO likes this

#4 eljefe

eljefe

    New Boss 302 Member

  • Northeast Region
  • 5 posts
  • Region:U.S., Northeast
  • Current Vehicle:BOSS 302 Laguna Seca
  • Boss 302's Year:2012

Posted 06 August 2017 - 07:18 AM

Thanks for the replies guys.

 

It is an NA car, completely stock.

 

I started the car just a few minutes ago and the light is off and I'm getting a reading on the gauge in the center pod. However, the reading is very low, 10-20 PSI.

 

I have a Ford dealer less than 2 miles from me so I will try to get it to them ASAP and have it checked out. I'll keep you posted.


Edited by eljefe, 06 August 2017 - 07:33 AM.


#5 Rich B.

Rich B.

    Rich B.

  • Northeast Region
  • 3,449 posts
  • Region:U.S., Northeast
  • Current Vehicle:Boss 302 and '16 Buick LaCrosse
  • Boss 302's Year:2013

Posted 06 August 2017 - 10:20 AM

Oh too, remember one time I lost oil pressure on my road runner. What had happened one of the carb floats had filled up with gas, flooding engine. After all was said and done I probably had a few gallons of gas that had drained off in the crankcase. That was a Carter AFB and switched to a Holly advertised at about 5 more HP. Nice clean motor anyways.

#6 LSECO

LSECO

    LSECO

  • Pacific Coast Region
  • 3,426 posts
  • Region:U.S., Pacific Coast
  • Current Vehicle:2012 Boss 302 L S # 482 blk/red
  • Boss 302's Year:2012
Garage View Garage

Posted 06 August 2017 - 11:09 AM




Sure am interested in your prognosis,as a fellow '12 LS owner.actually, quite a few Boss owners installed the pod.
Any '13 owners add the pod?



Had an F150 with a 460 cu.in.

Occasionally a back-fire on start up would blow the power valve causing a very rich gas flow. Had to replace it a few times,But what a hill climbing 4X4 powerhouse.
<p><p> 2012 LAGUNA SECA Black/Race Red: The FIRST year of the RETURN of the Boss 302, (Gen.II) Road-Race ready.
L O - J A C K theft recovery system.
Pedestal wing with GT-500 Gurney flap,modified fr. splitter.Halon fire extinguisher.Cervini ram air hood w/heat extractors. Recaro racing seats, race red rear seat delete brace bar,4pt.race red seatbelts and harness bar,r.r. front splitter adj.rods,r.r.coil covers and r.r.shock tower brace.LS race gauge pack.FRPP race brake cooling ducts, Motul 600 race brake fluid, FRPP trans cooling scoop, AEM intake tube kit, oil catch can-pass side only, FRPP TRACKEY,SilverHorse gas filler lid.MMD satin black tail light surrounds,MMD Carbon fiber wrapped hood gas struts, projector headlights w/sequential turn signals and emergencies,rear brake/emergencies sequencers.CSI protective smoke head light covers-daytime use only, satin black LS faux gas cap.Honeycomb ELEANOR grill w/hidden LED HALO fogs,honeycomb front lower grill,limo tint on rear glass ONLY,LED interior, license plate, and trunk lighting, satin silver billet e-brake handle, mirror adj.knob ,shifter ball,rear seatbelt mounting covers.Eibach Sportline road racing lowering springs(installed by Eibach), FRPP 1pc. aluminium drive shaft,Bama "tunes for life", Kooks long tube headers,Kooks cat delete offroad X-pipe,resonator delete over axle pipes,On-3-Go muffler deletes.
Custom smoke/nickel chrome, LIGHTWEIGHT 19X10 wheels-295×30×19 fronts-295x30x19 rears w/Hoosier R6 tyres for spirited driving, Pirelli P Zero Corsa tires on stock RED rims for inclement monsoon weather, Carbotech brake pads, race red Brembo calipers,FRPP GT500 rear rotors conversion, MGW Race spec.III shifter,Whiteline trans mount bushing, J&M adjustable panhard bar.Dual clutch transmission fluids,

(just a SMIDGEON of mods compared to most of "MY BOSSBROS") All LS take-off parts are packaged up..... There is no such thing as a "REGULAR" Boss !!   :rockon:   


                                 

#7 GrabberBlue

GrabberBlue

    New Boss 302 Member

  • Great Lakes Region
  • 38 posts
  • Region:U.S., Great Lakes
  • Current Vehicle:'13 Grabber Blue Boss 302 #3459
  • Boss 302's Year:2013

Posted 06 August 2017 - 03:59 PM

I would stop driving the car unless you verify good oil pressure with a mechanical gauge. Otherwise tow it to the dealer.
  • LSECO likes this

#8 eljefe

eljefe

    New Boss 302 Member

  • Northeast Region
  • 5 posts
  • Region:U.S., Northeast
  • Current Vehicle:BOSS 302 Laguna Seca
  • Boss 302's Year:2012

Posted 09 August 2017 - 07:02 PM

Dropped the car off at the dealer yesterday. I got a call in the afternoon telling me they need to replace the oil pressure 'switch' and was given part number GC3Z9278A. When I searched for the part number for a 2012 BOSS oil pressure sensor it shows CR3Z9D290A. The part number they gave me is what comes up when they plug my VIN in but it is not the original part. I spoke to them this morning and told them to go with the original part which unfortunately is a LOT more money.
 
Here is a (very shaky) video I captured yesterday as I was dropping the car off. You can see what is going on with the gauge going nuts while at idle and warning light.
 
 

 



#9 Rich B.

Rich B.

    Rich B.

  • Northeast Region
  • 3,449 posts
  • Region:U.S., Northeast
  • Current Vehicle:Boss 302 and '16 Buick LaCrosse
  • Boss 302's Year:2013

Posted 10 August 2017 - 05:27 PM

Yes, that's crazy, almost looks like a bad connection. Those must be electrical sending through a variable ground/negative resistance? I would go with the sender # for the dash pack, as like the 13's have built in dash pressure gauge display. Maybe that's the # dealer is bringing up?

Remember when you hooked up the flex poly tube with fittings for actual oil pressure with the gauge sets. Not good when one of those wore or melted through or broke, oil all over the place.

#10 Ginger

Ginger

    New Boss 302 Member

  • Member
  • Pip
  • 157 posts
  • Region:Other
  • Current Vehicle:2012 Boss 302
  • Boss 302's Year:2012

Posted 11 August 2017 - 01:35 PM

Yea I have to agree with Rich. You have an electrical (Grounding / sending unit) or bad gauge problem. If you have zero oil pressure the motor would be tap dancing like crazy. I will bet its an easy fix. Just a thought.... A standard boss has no gauges, just a light. Dose the LS which has the gauge also have the light. So that leads me to believe its not a motor / bearing problem.



#11 eljefe

eljefe

    New Boss 302 Member

  • Northeast Region
  • 5 posts
  • Region:U.S., Northeast
  • Current Vehicle:BOSS 302 Laguna Seca
  • Boss 302's Year:2012

Posted 15 August 2017 - 07:18 PM

Finally got her back today after sitting at the dealer since last Tuesday. Took 5 days to get the new part. I think the tech may have even done some extra heat shield wrapping on those cables coming out of the sensor because I remember seeing the electrical wires sticking out of the end of it on the old one. Went for a test drive and everything is working fine now.

 

36200704270_22b50095f9_b.jpg


Edited by eljefe, 15 August 2017 - 07:19 PM.

  • Rich B. likes this

#12 BDAutobahn

BDAutobahn

    New Boss 302 Member

  • Great Lakes Region
  • 119 posts
  • Region:U.S., Northern Plains
  • Current Vehicle:2013 Boss 302 Laguna Seca

Posted 16 August 2017 - 03:41 PM

I'm sorry El Jefe.  That surely must have been frustrating.  Sending you some good vibes.  Best wishes!



#13 eljefe

eljefe

    New Boss 302 Member

  • Northeast Region
  • 5 posts
  • Region:U.S., Northeast
  • Current Vehicle:BOSS 302 Laguna Seca
  • Boss 302's Year:2012

Posted 16 August 2017 - 07:43 PM

I'm sorry El Jefe.  That surely must have been frustrating.  Sending you some good vibes.  Best wishes!

 

Thank you so much. Yeah, I went through serious withdrawals there for a few days :waiting:  



#14 TymeSlayer

TymeSlayer

    TymeSlayer

  • Mountain Region
  • 2,969 posts
  • Region:U.S., Mountain
  • Current Vehicle:2013 Ford Edge Limited - 2012 Kona Blue Boss 302 - 2008 Mercury Mountaineer Premier
  • Boss 302's Year:2012
Garage View Garage

Posted 17 August 2017 - 04:20 PM

If anyone is ever looking for that oil sensor, I have a spare. Ford sent two in my LS gauge kit. 

 

 

 

Attached File  NEW - SSI - Oil Pressure Gauge for LS Gauge Pack - P51-100-G-A-P-4.5V-000-000 .JPG   109.52KB   0 downloads


  • LSECO, Ginger and Rich B. like this

FRPP 84.5MM Throttle Body / 302S Bumpsteer Kit / FR500S Front Wheel Hub and Rear Wheel Studs / Front Brake Cooling Ducts / LS Dash Gauges / LS Pedestal Spoiler / Recaro Seats/ Stainless Steel Clutch Line / T-Springs / Torsen Differential / TracKey -  BFR Aluminum Rear Brake Caliper Bracket / Fire Extinguisher Mount / Front Tow Hook Kit - BMR A-Arms / Front Drive Shaft Safety Loop / K-Member / Lower Control Arms / Radiator Support / Upper Control Arms / Watts Link - ForgeStar CF5V Matte Black – Mickey Thompson Street Comps - Hawk High Performance Ceramic Pads  - DBA Slotted Rotors - Goodridge Stainless Steel Brake Lines - Kooks Shorty’s Headers / Boss 302 Side Pipes – Borla ATAKs Axle Backs / 2-3/4” Over Axle – MRT H-Pipes -QTP Electric Cutouts - Driveshaft Shop One Piece Aluminum Driveshaft - Airaid Parnelli Jones Cold Air Intake - CoolTech Boss 302 Oil Cooler with T-Stat / 6PT Harness Belts and Clips - Corbeau Harness Bar - Peterson Air-Oil Separator - Moroso Overflow Tank - SPEC Stage 2+ Clutch Kit / Lightweight Steel Flywheel - MGW Race Spec Shifter - Koni Yellow Sports - Maximum Motorsport Caster-Camber Plates  - Aggressor Airflow Engraved Front Splitter

 

Member: FRMC - MCA - NASA Rocky Mountain

 

Sweet Lorraine - Circa March 2015

 

 


#15 LSECO

LSECO

    LSECO

  • Pacific Coast Region
  • 3,426 posts
  • Region:U.S., Pacific Coast
  • Current Vehicle:2012 Boss 302 L S # 482 blk/red
  • Boss 302's Year:2012
Garage View Garage

Posted 18 August 2017 - 04:15 AM

Why might the sensor fail--most likely heat related ?
<p><p> 2012 LAGUNA SECA Black/Race Red: The FIRST year of the RETURN of the Boss 302, (Gen.II) Road-Race ready.
L O - J A C K theft recovery system.
Pedestal wing with GT-500 Gurney flap,modified fr. splitter.Halon fire extinguisher.Cervini ram air hood w/heat extractors. Recaro racing seats, race red rear seat delete brace bar,4pt.race red seatbelts and harness bar,r.r. front splitter adj.rods,r.r.coil covers and r.r.shock tower brace.LS race gauge pack.FRPP race brake cooling ducts, Motul 600 race brake fluid, FRPP trans cooling scoop, AEM intake tube kit, oil catch can-pass side only, FRPP TRACKEY,SilverHorse gas filler lid.MMD satin black tail light surrounds,MMD Carbon fiber wrapped hood gas struts, projector headlights w/sequential turn signals and emergencies,rear brake/emergencies sequencers.CSI protective smoke head light covers-daytime use only, satin black LS faux gas cap.Honeycomb ELEANOR grill w/hidden LED HALO fogs,honeycomb front lower grill,limo tint on rear glass ONLY,LED interior, license plate, and trunk lighting, satin silver billet e-brake handle, mirror adj.knob ,shifter ball,rear seatbelt mounting covers.Eibach Sportline road racing lowering springs(installed by Eibach), FRPP 1pc. aluminium drive shaft,Bama "tunes for life", Kooks long tube headers,Kooks cat delete offroad X-pipe,resonator delete over axle pipes,On-3-Go muffler deletes.
Custom smoke/nickel chrome, LIGHTWEIGHT 19X10 wheels-295×30×19 fronts-295x30x19 rears w/Hoosier R6 tyres for spirited driving, Pirelli P Zero Corsa tires on stock RED rims for inclement monsoon weather, Carbotech brake pads, race red Brembo calipers,FRPP GT500 rear rotors conversion, MGW Race spec.III shifter,Whiteline trans mount bushing, J&M adjustable panhard bar.Dual clutch transmission fluids,

(just a SMIDGEON of mods compared to most of "MY BOSSBROS") All LS take-off parts are packaged up..... There is no such thing as a "REGULAR" Boss !!   :rockon:   


                                 








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·